Critical Internet Explorer exploit – Update NOW!

Three days after patching 3 known vulnerabilities in Internet Explorer, a vulnerability in Internet Explorer 8 has already been exploited. Microsoft and security professionals agree that if you have not run the latest round of updates for your systems running Internet Explorer 6, 7, or 8, do so now or upgrade to Internet Explorer 9 immediately. The exploit in question abuses a hole found in IE that simply by browsing to a compromised site, automatically downloads malicious software to a user's local machine. This software then connects to a remote server to await instructions on how to exploit the user's system.

With hackers breaking into more and more companies every day, and phishing attacks on the rise, how is a small business as yours able to cope with so many security issues? At Renascence IT Consulting, we can help you lock down your company and teach your employees how to use business computers safely, without needing a Fortune 500 IT budget. Contact us for more information!

More on the Exploit:

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s